Solved: Problems with WyzeCam Android Client

I’ve become a huge fan of the WyzeCam IP cameras. They’re small, very high quality, and have a very good mobile client to connect to them. But sometimes, the mobile client will refuse to start. It comes up with the startup screen, and never proceeds.

Searching around the Reddit and WyzeCam forums, many people have seen this happen, but there’s not a clear reason why.

I’ve had this happen on occasion on my Samsung S9+, and I’ve finally found a pattern – it’s quite simple actually.

On the loading screen, the client is making it’s initial connections to WyzeCam’s cloud services. But it’s quite common for providers, corporate networks, and sometimes even hotels or wifi hotspots to block connections to certain services. If the phone cannot connect to the cloud service, it will sit stuck at that startup screen forever, without ever doing anything.

I discovered this when my phone had connected to a mobile hotspot in the office which required authentication to start operating. The phone was connected, but could not reach the internet. The WyzeCam app was sticking at the opening screen. Once I completed the registration, and reloaded the Cam app, it came up super-fast.

I was able to duplicate this experience at a hotel stay recently as well. The local wifi was extremely crowded and performing extremely badly. The WyzeCam app was hanging at the startup screen again. As soon as I switched my phone from the WiFi to my carrier data, the screen loaded correctly!

I think Wyze could fix this very easily by giving some feedback on the loading screen, showing it’s trying to connect, and giving a timeout message if it fails after X amount of time. But for now, this frustrating behaviour is easy to understand and deal with.

primark

About

A wandering geek. Toys, shiny things, pursuits and distractions.

View all posts by

Leave a Reply

Your email address will not be published. Required fields are marked *